View Issue Details

IDProjectCategoryView StatusLast Update
0002439SymmetricDSBugpublic2022-08-02 18:53
Reporterrotten Assigned Toelong  
Status closedResolutionfixed 
Product Version3.7.26 
Target Version3.12.0Fixed in Version3.12.0 
Summary0002439: PostgreSQL 9.5 Beta 1 no longer supports autocommit option
DescriptionWhen I try to run dbimport for a new PostgreSQL 9.5 (Beta 1) database I get this error:

org.postgresql.util.PSQLException: ERROR: unrecognized configuration parameter "autocommit"

It appears 9.5 has removed support for this configuration option.

"Remove server configuration parameter autocommit, which was already deprecated and non-operational (Tom Lane)"
Steps To ReproduceStand up a 9.5 database and try to load a table using dbimport.
Additional InformationI haven't figured out a work-around yet.
Tagsdialect: postgresql, install



2015-11-05 20:25

reporter   ~0000728

Since I'm loading into PostgreSQL, I used the 'copy table from' command to do the import from the dbexport files.


2016-02-03 02:01

reporter   ~0000757

Last edited: 2016-02-03 02:02

View 2 revisions

Now that postgresql-9.5 is in production, we upgraded it and I see symmetric cannot connect to the database. Here is the error:

`2016-02-03 01:45:13,622 ERROR [server-000] [AbstractSymmetricEngine] [symmetric-engine-startup-0] Could not get a connection to the database: Cannot create PoolableConnectionFactory (ERROR: unrecognized configuration parameter "autocommit"). Waiting for 10 seconds before trying to connect to the database again.`

Any workaround for time being is appreciated. Thanks.


2016-03-22 20:10

reporter   ~0000770

Last edited: 2016-03-23 08:53

View 2 revisions

You need to (self-)update the JDBC driver for postgresql:

remove "set autocommit = ON"

in seems there is currently no fix for this provided yet.


If you create a .jar from the corresponding .java file (only with that .java) you should be able to put that in the "patches" folder of your SymmetricDS installation, to get this working.


2016-11-14 15:47

reporter   ~0000904

I confirm workaround above works, but this looks like to much of hassle. Postgresql 9.5 should work out of the box.


2016-11-14 16:55

administrator   ~0000905

You can remove protocolVersion=2 from the jdbc url. It was added because of this issue:

Maybe postgres 9.5 and higher have solved the plan issue.


2016-11-14 22:21

reporter   ~0000906

To work around the "autocommit" error, the PostgreSQL JDBC driver shipped with SymmetricDS needs to be updated:
1. download the latest PostgreSQL JDBC driver from There are different drivers depending on the level of JDK (“java -version”).
2. put the downloaded jar file in the “../symmetric-server-3.8.8/patches” directory.

I tried the latest "postgresql-9.4.1212.jar and the SymmetricDS "tutorial" went through on PostgreSQL v9.5 databases.

Issue History

Date Modified Username Field Change
2015-11-05 19:23 rotten New Issue
2015-11-05 20:25 rotten Note Added: 0000728
2016-02-03 02:01 moizhb Note Added: 0000757
2016-02-03 02:02 moizhb Note Edited: 0000757 View Revisions
2016-03-22 20:10 woehrl01 Note Added: 0000770
2016-03-23 08:53 woehrl01 Note Edited: 0000770 View Revisions
2016-11-14 15:47 alex_val Note Added: 0000904
2016-11-14 16:55 chenson Note Added: 0000905
2016-11-14 22:21 davesharpe13 Note Added: 0000906
2019-04-23 20:21 elong Tag Attached: postgresql
2019-04-23 20:21 elong Tag Attached: install
2019-04-23 20:50 admin Tag Renamed postgresql => dialect: postgresql
2022-08-02 18:53 elong Assigned To => elong
2022-08-02 18:53 elong Status new => closed
2022-08-02 18:53 elong Resolution open => fixed
2022-08-02 18:53 elong Fixed in Version => 3.12.0